NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Issues building NetBSD with GCC 10

I tried building NetBSD on Linux host with GCC 10 as the default system
compiler and ran into various issues:

- Tried building netbsd-9 and that fails to build bmake tool due to
duplicate symbols or something. This seems to have been fixed in
netbsd-current, so would this be backported to other branches?

- Tried building netbsd-current but it fails to configure mpfr due to
missing libgmp. Is this a known issue?

configure: error: libgmp not found or uses a different ABI (including static vs shared).
Please read the INSTALL file -- see "In case of problem".

*** Failed target: .configure_done
*** Failed commands:
        @mkdir build 2>/dev/null || true
        @(cd build && ${CONFIGURE_ENV} ${HOST_SH} ${GNUHOSTDIST}/configure ${CONFIGURE_ARGS})
        @echo ${BUILD_PLATFORM} > $@
*** [.configure_done] Error code 1

nbmake[7]: stopped in /netbsd_build/netbsd-current-src/tools/mpfr
1 error

Home | Main Index | Thread Index | Old Index