NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Broadcom interface issues


I have a laptop which has the bwi0 card (internal)

[     1.044827] bwi0 at pci4 dev 2 function 0: Broadcom Wireless
[     1.044827] bwi0: interrupting at ioapic0 pin 22
[     1.044827] bwi0: BBP id 0x4318, BBP rev 0x2, BBP pkg 2
[     1.044827] bwi0: MAC: rev 9
[     1.044827] bwi0: PHY type 2, rev 7, ver 3
[     1.044827] bwi0: RF manu 0x17f, type 0x2050, rev 8
[     1.044827] bwi0: autoconfiguration error: invalid antenna gain in sprom
[     1.044827] bwi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
[     1.044827] bwi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps
12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps

I installed the firmware... and I can "swear" that the first time I
tried it did work. Or it did work by trying to bring it down and up and
at the second attempt it worked (typical! have this issue with many
cards also on linux....)

I used the firmware cited in the man page:

and it is still there:
ls  /libdata/firmware/bwi/v3/
a0g0bsinitvals2.fw  a0g0initvals2.fw    a0g1bsinitvals5.fw 
b0g0bsinitvals2.fw  b0g0initvals2.fw    pcm4.fw            
ucode11.fw          ucode4.fw
a0g0bsinitvals5.fw  a0g0initvals5.fw    a0g1initvals5.fw   
b0g0bsinitvals5.fw  b0g0initvals5.fw    pcm5.fw            
ucode2.fw           ucode5.fw

Now, everytime I use it, it doesn't...
When I bring it up (ifconfig bwi0 up) I get the familiar message:
[   138.358643] bwi0: firmware rev 0x0127, patch level 0x000e

And the led brightens up.
Now I can configure the ssid, for example, set nwid, set nwkey.

First, at every command I sent, I get again the firmware message (is it
normal? or does it try to load and reload??)

It appears to get the parameters, but... never connects. All tricks I
know.. like configuring, waiting... setting first nwid, then key... or
trying up/down a couple of times, nothing)
The interface stubbornly reports:

        status: no network

The interface is enabled in the BIOS and there is no hardware switch.

Any ideas?


Home | Main Index | Thread Index | Old Index