NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Can't build 5.1.2 kernel (solved)

Hello Frank,

Good to hear from you.

On Fri, 16 Nov 2012, Frank Wille wrote:
Subject: Re: Can't build 5.1.2 kernel (solved)

On Fri, 16 Nov 2012 08:55:47 -0500 (EST)
Al <> wrote:

I just wanted to let everyone know just how well NetBSD 6 works!
There have been major improvements. In fact, it even seems a little
bit faster when doing most things. I am very happy with it. I would
recommend that everyone upgrades.

Nice to hear! :)
So there are no problems left?

Yes, all the problems that I have been having with NetBSD 4 have gone away. I am really not sure what I did to NetBSD 4 to cause the problems I was having, but there were some major issues. Now, I can untar many tar balls at one time and the system doesn't crash. I can also use cvs. There are other things that are working too. It caches some of the things when it is running ./configure when building a package. This makes this a little bit faster. Transfer rates seem much higher on the system that I have co-located. On a system that I have here locally connecting to the internet via a satellite connection now named works. I can do an nslookup and use the name server that is on this system and I get an IP. In fact, networking has seemed to improve too. There are so many good things to say about NetBSD 6.

I have several things in my dmesg that I didn't see before. So, I have a few questions about them.

---snip from dmesg---
WARNING: no TOD clock present
WARNING: using filesystem time

I believe this is what John Klos was referring to in one of his recent emails.

---snip from dmesg---
/dev/sd0a: `-o softdep' is no longer supported, consider `-o log'
/dev/sd0e: `-o softdep' is no longer supported, consider `-o log'
/dev/sd0f: `-o softdep' is no longer supported, consider `-o log'

I know this is because softdep is no longer supported and removing softdep from my fstab will fix this. Still it doesn't seem to create any real issues.

Can I switch to log with an existing file system? I am not sure if I even have this compiled in.

---snip from dmesg--
cprng sysctl: WARNING pseudorandom rekeying.

I am not sure what is causing this last one. Could it be caused from my sysctl.conf?


There is one other thing and that is that I can't build mysql-client. It always ends in an error. I am trying from the latest stable pkgsrc. I just downloaded pkgsrc-current and I am going to see if it will build with that.

Also, I had this problem on NetBSD 4 too. I can not build bogofilter because one of the dependents no longer has a 68k version. I guess that I could see if there is a way to build bogofilter without this dependency.

Also, is it possible to build packages on a faster system (like macppc) and then install them on my port-amiga NetBSD systems using pkg_add? It takes a very long time to compile some packages.

Thank you,

Home | Main Index | Thread Index | Old Index