NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Compiling 6.0_RC1 fails

On Mon, 17 Sep 2012, Pongthep Kulkrisada wrote:

Hi All,

Firstly, I'm very new to NetBSD.
I'm now using NetBSD 5.1_STABLE on i386.
I have done cvs to 6.0_RC1 (I want to test it).
I tried building both userland and the kernel.
But compiling the new userland fails at some point (after 2 hours elapsed).
And I tried compiling the new kernel; it also fails (after 5 minutes elapsed).
I cannot log error messages.
(I don't think script(1) can do such a large file.)

script should do that just fine, unless your output file exceeds the free space of the indicated file system.

I don't know if it is listed in PR. So I come here first.
I used the same procedure when I successfully made STABLE from NetBSD 5.1.2.
That time, I built both userland and the kernel.
But this time, it just fails.

I shall try installing from iso...

Good idea.  Are you missing any steps?:

$ ./ -r -x -O ../obj -T ../tools -U distribution

$ ./ -O ../obj -T ../tools -U kernel=YourKernel

$ cd ../obj/sys/arch/i386/compile/YourKernel
$ su
# pwd
# mv /netbsd /netbsd.old
# mv netbsd /netbsd
# shutdown -r now

$ cd /usr/src
$ su
# ./ -x -O ../obj -T ../tools -U install=/

!-- in this case:
# /usr/src/usr.sbin/postinstall/postinstall -s '/usr/src' -d //
        fix makedev mtree motd pkw_mkdb rc obsolete
# etcupdate -v
!-- follow the output
# shutdown -r now


Home | Main Index | Thread Index | Old Index