NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: iscsi initiator troubles

On Mon, Sep 26, 2011 at 06:34:13PM -0400, John Jaser wrote:
> Hi,
> I've been struggling for a few days getting iscsi_initiator talking to a
> netbsd 5.1 iscsi-target. The iscsi-target has been performing well for about a
> solid week as a back-end for a debian 6.0 xen server using open-iscsi. Getting
> a netbsd 5.1 xen server to do the same has been the challenge. All systems are
> amd64 with 8G RAM, using amd64 kernels.
> The symptom is not apparent until file creation, but happens rather quickly.
> The file copy or dd empty-file creation will just hang, or sometimes barely
> get started. The system becomes unresponsive. The 'top' process list in
> another terminal continues to run, and shows almost no load (too low) even on
> the iscsi-initiator process and the dd or cp process. New terminal logins
> work, but any command other than an 'ls' hangs also, and the situation
> deteriorates until a dirty restart is required. I also tried using
> iscsi_initiator on the iscsi-target system with similar results. Lastly, I
> tried enabling iscsi-target on the iscsi_initiator host itself, and got the
> same result. That session is below. Of interest may be the two errors in the
> syslog followed by the successful login. I tried the 5.1-XEN kernel(with
> puffs), the generic 5.1 kernel, and a current kernel from last week; all gave
> same result. Seems almost like some kind of deadlock, since the load is so
> low. Any tips would be greatly appreciated.

When doing this, did you watch if the free memory becomes too low
(top should tell you that)

Manuel Bouyer <>
     NetBSD: 26 ans d'experience feront toujours la difference

Home | Main Index | Thread Index | Old Index