NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: tracking current / kernel modules

    Assuming you have recent -current, try:

        cd /usr/src
        ./ modules installmodules=/

You might want to try someplace other than "/" the first time
through to be safe; I haven't tried it myself yet.

thanks.. I was looking for such a command... I (should) have an updated tool dir and a kernel ready to be installed according to the update guide.

When I run your command I get, after some compilation,

dependall ===> sys/modules/accf_dataready
#    create  accf_dataready/accf_data.d
CC=/usr/src/obj/tooldir.NetBSD-5.99.48-i386/bin/i486--netbsdelf-gcc /usr/src/obj/tooldir.NetBSD-5.99.48-i386/bin/nbmkdep -f accf_data.d -- -I/usr/src/common/include --sysroot=/usr/src/obj/destdir.i386 -I/usr/src/common/include -nostdinc -I. -I/usr/src/sys/modules/accf_dataready -isystem /usr/src/sys -isystem /usr/src/sys/arch -isystem /usr/src/sys/../common/include -D_KERNEL -D_LKM -D_MODULE -DSYSCTL_INCLUDE_DESCR /usr/src/sys/netinet/accf_data.c
sh: /usr/src/obj/tooldir.NetBSD-5.99.48-i386/bin/nbmkdep: not found

*** Failed target:  accf_data.d

Where is the problem? something inconsistent on my side? A problem with build-sh run of makedepend?


Home | Main Index | Thread Index | Old Index