NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Upgrade failure

I just hurt myself real bad!  :)

Seriously, I'm not hurt, but my main NetBSD server is dead.

I was in the process of updating it from a several-months-old 5.99.39 to today's current. I had already installed and booted the new kernel, with new /stand/amd64/5/99/43/modules/ installed, with no problem, so I installed userland. At the same time, I had added some stuff to /etc/rc.local to load several modules at boot time: acpibut, acpicpu, acpipmtr, and acpitz.

Unfortunately, when I booted, the system it failed to build the pwd.db files, and I could not get pwd_mkdb to do anything useful. It kept complaining that it couldn't create the output files, but gave no further info. I grabbed the files from another machine that had been updated successfully, and the machine seemed to be happy.

However, on the next boot, the box locked up solid. I mean SOLID! It doesn't even turn on the fans any more, and it won't even start the power-on self-test. I pulled the battery and tried to reset the BIOS settings, but that did not work either.

Does anyone have any clue about how loading the acpixxx modules could have confused the box so thoroughly? And is there any hope of getting it operational again? (I've tried complete removal of power, as well as removing the BIOS battery, but no luck.)

| Paul Goyette     | PGP Key fingerprint:     | E-mail addresses:       |
| Customer Service | FA29 0E3B 35AF E8AE 6651 | paul at    |
| Network Engineer | 0786 F758 55DE 53BA 7731 | pgoyette at |
| Kernel Developer |                          | pgoyette at  |

Home | Main Index | Thread Index | Old Index