NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Huawei E1820

Also consider trying a -current GENERIC - some of these devices require some 
strange contortions to get them working, and current has more of them.


"Jukka Marin" <> wrote:

>On Thu, Nov 25, 2010 at 11:10:47AM -0800, Jeff Rizzo wrote:
>> On 11/25/10 9:53 AM, Jukka Marin wrote:
>> >Hi,
>> >
>> >Does anyone happen to know how to make Huawei E1820 3G USB stick
>work with
>> >NetBSD?  When I plug it in, NetBSD sees two umass devices but no
>> >I tried the stick on a mac and after installing the software, it
>> >but
>> >it still doesn't work with NetBSD.
>> >
>> >(I would like it to work on NetBSD 4.0 because that's what my ARM
>> >router is running...)
>> The u3g driver (which is probably what should match it) does not
>> to be in netbsd-4;  have you tried it in -current or at least
>> If it works there, it should be easy enough to patch netbsd-4 to
>> it.  If not, that's where we should start.
>I tried it on 5.1_RC3.  The product ID does not exist in usbdevs - I
>adding it there and also added the defines to uhmodem.c (I'm running
>now).  I guess u3g.c sounds like a more appropriate driver, now that I
>of it ;-)
>  -jm

Sent from my Android phone with K-9 Mail. Please excuse my brevity.

Home | Main Index | Thread Index | Old Index