NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

libssh2 - openssl issue

Hi there!

I was installing libssh2 and then noticed following:

$ pwd
$ head config.log

  $ ./configure --with-libgcrypt=no --with-libz=/usr --with-openssl=/usr
--prefix=/usr/pkg --build=x86_64--netbsd --host=x86_64--netbsd


Especially the option "--with-openssl=/usr" makes me kind of angry. I
remember having had the same issue with "tor". Is there any reasons why
the openssl libraries in /usr/lib should be used instead of those in
/usr/pkg/lib ?

Is there any way to specify this one option(--with-openssl=/usr/pkg)
without modifing the Makefile?

BTW: In the Makefile you'll find:
CONFIGURE_ARGS+=    --with-openssl=${SSLBASE:Q}

Where is this variable ${SSLBASE:Q} set?

Victor Dorneanu

- Web/Blog:
GnuPG information
- KeyID = 0xD20870F4 (
- Key fingerprint = DD6B 5E09 242F 7410 3F90 492A 4CBA FD13 D208 70F4

Home | Main Index | Thread Index | Old Index