NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Substantial COMPAT_LINUX changes in netbsd-5?

On 1/15/10 5:26 PM, Fredrik Pettai wrote:
> On Jan 15, 2010, at 4:55 PM, Christos Zoulas wrote:
>> In article <>,
>> Fredrik Pettai  <> wrote:
>>> On 1/14/10 6:16 PM, Hauke Fath wrote:


>>> After that, we at least got a full backup to work, but the incremental
>>> backups still fails. It doesn't feel stable ATM. I just noticed that the
>>> df command seems to get "blocked" during a incremental backup try.
> [...]
>> I think that the namei changes that handle the emulated root could be at
>> fault here, or NFS. Have you tried using a loopback mount?

I notice that there where some old bpbkar processes hanging, so I tried
to kill 'em. But I never got them to die even with kill -9

So I did go for a full reboot of the machine and it hanged after
"unmounting file systems...". Probably because those bpbkar (Veritas
Netbackup) wheren't killed. So I entered the debugger (by break), and
did a reboot 2. I didn't though of it ATM, but would it help if I did a
bt or something else next time this happens? Seems to be easy to reproduce.

I doubt this is of much help, but I post it below:

syncing disks... 1 done
unmounting file systems...[-- break #0(1) sent -- `\z' -- Fri Jan 15
23:21:25 2010]
fatal breakpoint trap in supervisor mode
trap type 1 code 0 eip c055c1cc cs 8 eflags 202 cr2 bbaf30e1 ilevel 8
Stopped in pid 0.2 (system) at  netbsd:breakpoint+0x4:  popl    %ebp

The kernel is:
NetBSD 5.0.1_PATCH (MAIL-SERVER) #0: Mon Jan 11 12:33:13 CET 2010


Home | Main Index | Thread Index | Old Index