NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Problem with APCI on my laptop

Thank you for the reply.
I have tried it but it does not work.

On 08/22/2009 07:17 PM, Havard Eidnes wrote:
Hi list,
i have a problem with netbsd 5 on my laptop.
It does not recognize some hardware, included wpi(4) and bge(4)
If i disable ACPI it recognize both of them but they still not work (see
tail of netbsd5-generic-noacpi-dmesg for error messages).

I have included dmesg for GENERIC kernel booted with ACPI and with no
ACPI here:

I am not expert but i have noticed that with no ACPI the wpi(4) device
is attached to pci2, instead with ACPI the pci2 tell "no spaces enabled".
Similar with bge(4), but it is attached to pci3.
I'm far from an expert in this area, but it might be worth it to
experiment by turning one one or all of these options, found in
the i386 GENERIC kernel config:

# PCI fixups, for both PCIBIOS and ACPI
#options        PCI_ADDR_FIXUP          # fixup PCI I/O addresses
#options        PCI_BUS_FIXUP           # fixup PCI bus numbering
#options        PCI_INTR_FIXUP          # fixup PCI interrupt routing

Yes, this means you need a custom kernel...


- Håvard

Home | Main Index | Thread Index | Old Index