NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

long time firefox & thunderbird problems


   I've been having problems starting firefox and thunderbird for a long
time now (over a year). Sometimes it gets worse, and sometimes better.
But with the current iteration of drivers, X, dbus, firefox and
thunderbird, it's a half-hour job to get them working. In fact, I'm not
certain I can get them both running at the same time.

   The sympoms are: When I start firefox or thinderbird, I always get a
process. Sometimes I get an icon in WindowMaker, but it doesn't always
happen. And sometimes I get a really small empty window. Once they
[firefox & thunderbird] start behaving this way, it's virtually
impossible to start them (pkill thuderbird or pkill firefox, and then
attempt to start them again).

   I found a way to make it easier to start them: I start gimp (and
sometimes quit it again), and then start firefox/thunderbird, and
they'll start. Once they've started, I can quit them and restart them
again, as long as I don't push the system too much.

   I've have two primary suspects: Video drivers and/or dbus.

   I know from past experience that dbus is a huge source of problems.
Previously, I had some gtk programs crash on start. I found out that if
dbus isn't run as a daemon, it will start a dbus user process -- which
doesn't work properly and may case crashes. I installed dbus as a
daemon, and I could run those applications which previously kept
crashing on startup.

   When I run thundebird or firefox I get this:

gauss$ ps aux | grep dbus
jan     12959  0.0  0.0  15020   1596 ?     I    12:07PM 0:00.00
dbus-launch --autolaunch 342e6f0eae07e7a1b3d628884a5f0efe --binary
jan     25544  0.0  0.0   9992   1564 ?     Is   12:07PM 0:00.00
/usr/pkg/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --
dbus    28999  0.0  0.0   9992   1692 ?     Is   11:58AM 0:00.00
/usr/pkg/bin/dbus-daemon --system

   Is this normal?

   I should note that this problem suddenly appeared a long time ago.
Prior to that point, firefox and thunderbird worked perfecty, all the
time. It was a software upgrade (firefox/thunderbird)  which spawned the
problems. Since it was such a long time ago, I can't remember the exact
versions, but it may have been firefox 1.0.x and thunderbird 1.0.0, or
perhaps firefox 1.5.x, or so.

   I've used practically all versions of firefox and thunderbird from
the 1.0 versions in pkgsrc, and been using various versions of netbsd 3,
4 and 5 on three different computers.

   I've been sighing to myself for all this time, done my "launch
gimp"-trick, and accepted that it's how computers are supposed to work
nowadays. But now it's practically impossible to start firefox and

   Please read this before replying with the Standard Responses:
   - No, it's not broken profiles. I've tried with fresh profiles.
   - Yes, the memory chips are ok. I've had this problem for a _*long*_
time, and on two different systems. ONLY thunderbird and firefox are
affected. And I have run memory checks on the affected systems.
   - Yes, I have increased the number of available file handles.

   Any tips are welcome.

Kind regards,
Jan Danielsson

Attachment: signature.asc
Description: OpenPGP digital signature

Home | Main Index | Thread Index | Old Index