NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

AW: libgnomeprintui - gail - gtk problems ?

Hello and thanks for your fast reply

It seems to bet that it was to old me pkgsrc directory, after cvs update ist
running better thanks an see you

Betreff: Re: libgnomeprintui - gail - gtk problems ?

On Wed, 22 Apr 2009, Caloro Maurizio wrote:

> gtk2+-2.12.10     GIMP Toolkit v2 - libraries for building X11 user
> glib2-2.20.10     Some useful routines for C programming (glib2)

> ===> Creating toolchain wrappers for libgnomeprintui-2.18.2
> ERROR: gail>=1.8.0 is not installed; can't buildlink files. 
> *** Error code 1

(I sure dislike this error!)

This almost always means you have the dependency package already installed 
but the version is not good enough. This is caused by that dependency 
being indirect and being pulled in by a dependency that does have a good 
enough version.

My first suggestion is to update pkgsrc. The gail package was removed a 
few months ago, when it was integrated into gtk2. So after you update 
pkgsrc, remove your gail package (and I suggest you remove anything that 
requires gail). Then "make clean clean-depends" in the package you are 
trying to build. And then build again.

Home | Main Index | Thread Index | Old Index