NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Filesystem full? I've got 4.2TB free!

On Wed, 22 Apr 2009, Stephen Borrill wrote:
On Wed, 22 Apr 2009, Andy Ruhl wrote:
On Wed, Apr 22, 2009 at 3:11 AM, Stephen Borrill
<> wrote:
Filesystem in question is:

Filesystem  Size Used      Avail %Cap    iUsed   iAvail %iCap Mounted on
/dev/dk0    4.4T  39G       4.2T   0%   224044 592051282   0% /backup

I've been playing about with more and I'm getting more and more confused now :-/

I can touch /backup/dellboy/foo, but I cannot mkdir /backup/dellboy/foo.
rm -r /backup/dellboy then running rsync to recreate fails again, but not always at the same directory depth

Maybe I should just newfs it and stick with my hunch that WAPBL+crash has left remnants that fsck can't see.

I newfs'd and tried again twice; once with WAPBL and once without. I still get the same problem, so neither WAPBL or the crash are guilty. Similarly, I've gone back one level in the chain and newfs'd the raw device /dev/rld1d instead of creating a GPT wedge. Same problem.

The hardware is identical to another machine that's been running successfully for some time, so it's not a problem in, say, aac(4). The only difference between the two machines is one is running 4.0_STABLE and the other 5.0_RC2.

Once rsync has failed at certain place, it always fails at the same place.
Oddly though, if I delete the parent directory then rsync will get a little further before failing again on a new directory.


Home | Main Index | Thread Index | Old Index