NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkgtools: naming pkg* ones with/out _


Is there any specific reason, why some of pkgtools have _ why some of them not? It could be better to use same naming convention. Is it to distungusih 3rd party tools and natural ones? If so why pkg_rolling-replace is not included in NetBSD distro?

pkg_alternatives Generic wrappers for programs with similar interfaces
pkg_chk         Check installed package versions against pkgsrc
pkg_comp         Build packages inside a chroot jail
pkg_distinst Remove any distfiles not belonging to an installed package
pkg_filecheck         Check for files not owned by any package
pkg_install         Package management and administration tools for pkgsrc
pkg_install-info         Standalone GNU info file installation utility
pkg_leaves         Print leaf packages
pkg_notify Notifies package maintainer when a new version is available
pkg_online (V)         Client/Server search in pkgsrc packages
pkg_regress         Run pkgsrc infrastructure regression test suite
pkg_rolling-replace         Replace/upgrade packages in-place
pkg_select         Curses based pkgsrc system browser / manager
pkg_tarup         Generates binary package(s) from installed pkg(s)
pkgclean         Quickly clean up all work directories in pkgsrc
pkgdep Script for displaying dependence information on software packages
pkgdepgraph         Visual representation of installed NetBSD packages
pkgdiff         Tools to create, maintain and send back patches for pkgsrc
pkgfind         Find packages by package name in pkgsrc
pkglint         Verifier for NetBSD packages

and some more NetBSD ones:



Home | Main Index | Thread Index | Old Index