NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Tyan K8WE (S2895) Status

Hello all.  Can anyone with the afore-mentioned motherboard relate their 
experiences?  I'm particularly interested in how it runs amd64, and whether 
-current can see all ethernet ports and PCI (incl. -X and e) slots with ACPI 
enabled/disabled.  Has anyone tried the new BIOS update?  S2895's not EOL'd yet 
- though availability is getting sketchy...

Below is some of the stuff I've dug up so far...

<<Carlos T. Linares>>
<<4.99.64 amd64 on Tyan K8SD Pro (S2882-D)>>


On Sat, Jul 02, 2005 at 06:22:00AM +0000, Dave Huang wrote:

>       When using ACPI (acpi0 at mainbus0, options MPACPI, and
> options MPACPI_SCANPCI), NetBSD seems to configure only the PCI busses
> attached to the "main" nForce Professional 2200 chip of the Tyan
> Thunder K8WE (S2895) motherboard: it sees the first PCI Express slot
> and all of the onboard devices (SATA, USB, Firewire, etc...) except
> for the second Ethernet port. The second ethernet port and the second
> PCI Express slot are connected to a nForce Professional 2050 chip,
> which NetBSD doesn't detect. It also doesn't see any of the three
> PCI-X slots that are attached to the AMD 8131 PCI-X tunnel.
>       However, all PCI slots are detected when using MPBIOS.

I do see a similar issue with a Tyan s2885 (Thunder K8W) motherboard,
where the 2nd root bus isn't detected with ACPI kernels.

The problem is that the DSDT is missing the PCI Routing Table (_PRT)
for this bus, which is AFAIK mandatory.

I asked Tyan to fix the BIOS; but unfortunately, as my motherboard is
EOLed, they said that they won't correct it :-(

Nicolas Joly

Biological Software and Databanks.
Institut Pasteur, Paris.

Problem Fix Description:
- Changed PCI-e Slot 3 Option ROM default setting to [Enabled}
- Fixed an issue where you could not run 2x 7950GT video cards under Vista 
without getting a Code 12 in the device manager
- Fixed an issue where you could not run 2x 8800GT video cards under Vista 
without getting a Code 12 in the device manager
- Added bios option for enabling SLI for 88xx series video cards 

Home | Main Index | Thread Index | Old Index