NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

PLEASE HELP! mail not working :(

-------- Original-Nachricht --------
Datum: Sat, 07 Jun 2008 20:34:34 +0200
Von: "netbsd unix" <>
Betreff: PLEASE HELP! mail not working :(

Dear people,

With all due respect, after all these hours, I am getting quite fed up with 
NetBSD's mail system... on the other hand, I am not very experienced.

I once already had a discussion here about setting up e-mail, and after 
numerous hours, it finally worked; I wrote a short summary, and when I tried 
it... it DIDN'T work.

I am getting repeatedly a "smtp connection refused" error when I try to run 
fetchmail. telnet localhost 25 does not work either.

What I did so far:

The machine is connected to an internal network (in this case, of a dormitory) 
which, by DHCP, assigns the IP address to the machine. This happens 
every time the machine connects. How you find the ip-address, assuming your 
network card is ex0: ipconfig ex0. You are not being assigned anything else 
than this IP address. (No network name or similar).

You have the username "thatsme" (with the password "mypass", this password is 
not important here) on your local machine - let us call it as hostname, and as domain. Your mail 
provider is, with and used to send 
and receive mails; your username there is "", and 
password is "mymailpass".

What I did so far is:

in /etc/rc.conf write:


in /etc/hosts write: localhost -- whether it is this or does not make a 
difference, later on it just fails with if I leave the original value.

in /etc/postfix/ write:
myhostname =
mydomain =
mynetworks_style = host
relayhost =
smtp_generic = hash:/etc/postfix/generic

in /etc/postfix/generic write:

then issue the following commands:
# postmap /etc/postfix/generic && postfix check && /etc/rc.d/postfix reload'
$ date | mail -s TEST

Indeed, I got an e-mail with the date.

I use fetchmail, and in .fetchmailrc I wrote

poll protocol pop3 user "" password 

since .fetchmailrc must not have more rights that -rwx--x---, I set the rights 
with chmod as user thatsme:

chmod u=rwx,g=x,o= .fetchmailrc

now, I should be able to send and receive e-mails.

But when I now say

$ fetchmail -v

I see it successfully connects to, SEES that there are two 
e-mails, and is totally unable to actually GET them:
Trying to connect to failed
fetchmail: connection to localhost:smtp [] failed: Connection 
fetchmail: SMTP connect to localhost failed

PLEASE HELP! What's the matter with this?!

Kind regards,

GMX startet Hier findest Du Leute mit Deinen Interessen!
Jetzt dabei sein:

Psssst! Schon vom neuen GMX MultiMessenger gehört?
Der kann`s mit allen:

Home | Main Index | Thread Index | Old Index