NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

install/50343: pkgsrc bootstrap broken on fresh installation of NetBSD 7.0 amd64

>Number:         50343
>Category:       install
>Synopsis:       pkgsrc bootstrap broken on fresh installation of NetBSD 7.0 amd64
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    install-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Oct 18 20:45:00 +0000 2015
>Originator:     Magnus Ihse Bursie
>Release:        7.0
NetBSD 7.0 NetBSD 7.0 (GENERIC.201509250726Z) amd64

In short: It seems that chosing to install pkgin during the NetBSD installation process will render pkgsrc impossible to install out of the box.

In details: I'm used to Linux but new to NetBSD. I downloaded the 7.0 amd64 iso and booted it in VirtualBox. At the configuration step in the installation, I selected "Enable installation of binary packages" (which enabled pkgin). I also selected "Additional packages" and entered "bash". (I'm not sure if this is needed to reproduce, probably not.)

I did not choose to install pkgsrc, at that time.

Later on, I found out that without pkgsrc, a NetBSD installation is not very useful. I tried to install pkgsrc by running these steps as root:
# cd /tmp
# ftp
# tar -xzvf pkgsrc.tar.gz -C /usr
# cd /usr/pkgsrc/bootstrap/
# ./bootstrap

As I understand, that would be the recommended way to install pkgsrc. However, this fails. The problematic part of the log:
===> Installing for pkg_install-20150901
ERROR: pkg_install-20150508 is already installed - perhaps an older version?
ERROR: If so, you may use either of:
ERROR:     - "pkg_delete pkg_install-20150508" and "/usr/pkgsrc/bootstrap/work/bin/bmake reinstall"
ERROR:       to upgrade properly
ERROR:     - "/usr/pkgsrc/bootstrap/work/bin/bmake update" to rebuild the package and all
ERROR:       of its dependencies
ERROR:     - "/usr/pkgsrc/bootstrap/work/bin/bmake replace" to replace only the package without
ERROR:       re-linking dependencies, risking various problems.
*** Error code 1

bmake[2]: stopped in /usr/pkgsrc/pkgtools/pkg_install
*** Error code 1

bmake[1]: stopped in /usr/pkgsrc/pkgtools/pkg_install
*** Error code 1

bmake: stopped in /usr/pkgsrc/pkgtools/pkg_install
===> exited with status 1


As a NetBSD newcomer, I find it highly problematic that selecting an option during installation that was presented as a nice option ("binary packages", yeah, fine), makes a later installation of pkgsrc to fail.

The issue is probably fixable. I googled a bit and tried the three recommended solutions. Neither of these worked, but at that point I might have messed up the system too much. (I ended up doing a complete reinstall instead).

My main point here is not that it's a highly problematic bug, it's that it presents a unnecessary high and very disappointing barrier to a new user.
* Boot from NetBSD 7.0 ISO. 
* Select "Enable installation of binary packages" and enable it. 
* Also set "Additional packages" to "bash" (not sure it's needed)
* Download and unpack the stable pkgsrc.
* Run pkgsrc bootstrap.

Workaround: Do not install pkgin during installation time.

Home | Main Index | Thread Index | Old Index