Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: What to do with base X11 for netbsd-9 ?

On Sat, Jun 01, 2019 at 08:01:26PM +1000, matthew green wrote:
> so, i just updated a few X11 packages in -current.  as part
> of testing, i ran them on the sandy bridge laptop i've seen
> display glitches with the new intel driver on (mate-terminal).
> these glitches are now gone.
> can anyone with intel driver issues please try again with
> -current?  this may not help much older devices, but maybe
> it helps sorta older (eg, sandy bridge) systems?.

Tried with the old sandy bridge again:

[   819.027] (II) Module intel: vendor="X.Org Foundation"
[   819.027]    compiled for 1.20.5, module version = 2.99.917
[   819.039] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 30
[   819.039] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx;
 using a maximum of 2 threads
[   819.040] (II) intel(0): SNA initialized with Sandybridge (gen6, gt2) backend

Before all the updates, e.g. last year, it worked with SNA and no TearFree.

Now, when displaying images, e.g., with GraphicsMagick, I see
horizontal line segments which eventually get filled in. Otherwise,
e.g., all the xterms in the world, work fine, as do e.g. 2 copies
of  glmark2, with a score of 182.

Work arounds include (all with TearFree off):
- switch to UXA (glmark2 score of 50)
- switch to modesetting driver (glmark2 score of 50)

On another front, I cannot boot a computer with nouveau and a
NVidia GeForce GTX 680 (GK104). At the point where the console normally
changes resolution, the screen goes black and everything stops.
(No panic AFAICT)



Home | Main Index | Thread Index | Old Index