Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: job pipe read: no such process

On Mon, Feb 18, 2019 at 07:33:26AM +0700, Robert Elz wrote:
>     Date:        Sun, 17 Feb 2019 11:57:24 +0100
>     From:        Thomas Klausner <>
>     Message-ID:  <20190217105724.b7itw2iebg2znhei@danbala>
>   | I saw a new error today when building -current on 8.99.34/amd64:
>   | job pipe read: No such process
> That's a weird one.   The error is from make - and indicates that
> read() returned <0 with errno == ESRCH (this is in the code that
> handles -jN builds I think).   Exactly what that error is supposed
> to indicate I have no idea, ESRCH isn't a defined error from read()
> and I can't even imagine what it might ever be used for.
> The most likely cause would seem to be that a signal was caught, and
> did something which changed errno to ESRCH just after a read from
> a pipe had failed (presumably for some other reason - and failed,
> not just pipe closed/EOF).
> If that was what it was, it is not likely to be anything you can
> reproduce.

I tried again a couple days later and it worked fine.
Weird one :)

Home | Main Index | Thread Index | Old Index