Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: ThinkPad T42 w/-current, no mouse in X

I used to have this on my two T61p's all the time and have asked the list previously. Switching to a text console and back sorted it usually, so I wasn't bothered too much. Using gdm, there was some kind of a trick I had to do to get the mouse working - I had move the mouse cursor around before the gdm login window appeared; If I left this for  later, it couldn't come at all and I had to restart gdm. Go figure... 

Now unfortunately this is no longer a problem for me as both my T61p's packed (the well known NVidia substrate problem of the time struck them eventually, interestingly with a six month respite on one of them). My present laptop, an HP Envy 17, so far hasn't been able to run any Xorg server under NetBSD, neither the Intel 530 nor the GeForce 950M are usable for now; I run NetBSD only in text mode, plus a bunch of other systems with a gui (FreeBSD works fine, as well as each and every Linux I've bothered to try). 

But I digress. 

On Sun, 1 Jul 2018 at 22:13 John D. Baker <> wrote:
On Sun, 1 Jul 2018, Iain Hibbert wrote:

> On Sat, 30 Jun 2018, John D. Baker wrote:
> > I finally got around to starting X on it and was surprised when the mouse
> > didn't work.  No motion either through the trackpoint nub or the trackpad
> > and no evidence any buttons work.  The keyboard works fine once you get
> > a window active (Alt-Tab in fvwm).
> This also does not work on my T61p. I think somebody else reported that a
> while ago, not sure if there is a PR for it.

There's some initialization issue.  By accident, it worked fine for a
session, but when I quit and 'xdm' was resetting the Xserver, it stopped
working again.  Switching to a text console and back to the X display
made it start working again.

I seem to recall having to do this sort of thing before, but it's been
a while since I last played with -current X on this machine.

I don't recall having 8.0_RC2 misbehave but if it does the same action
will likely get it working again.

|/"\ John D. Baker, KN5UKS               NetBSD     Darwin/MacOS X
|\ / jdbaker[snail]mylinuxisp[flyspeck]com    OpenBSD            FreeBSD
| X  No HTML/proprietary data in email.   BSD just sits there and works!
|/ \ GPGkeyID:  D703 4A7E 479F 63F8 D3F4  BD99 9572 8F23 E4AD 1645

Home | Main Index | Thread Index | Old Index