Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Issues with i915drmkms on AMD64

Hi David,

Around two weeks ago, I had the same problem as yours, with
similar hardware.  But enabling genfb allowed me to preserve
the console at least until the kernel panic'd before running

I tried a brand new DRMKMS kernel today, and the situation has
improved.  The console works again (with no need to enable
genfb).  I still get the same panic at the end of the boot,

Here are some key messages from the dmesg (I don't have it in
full, I copied those by hand).

The kernel was booted with -xv.

i915drmkms0 at pci0 dev 2 function ...
pci_mem_find: void region
pci_mem_find: void region
i915drmkms0: map 5 failed
DRM debug in drm_minor_register:
(several times)
DRM debug in i915_dump_device_info: gen=5, ...
pci_mem_find: void region
(several times)
DRM error in i915_driver_load: failed to map registers
i915drmkms0: unable to attach drm: 5


init: copying out path `/sbin/init' ...
panic: cnopen: no console device



Home | Main Index | Thread Index | Old Index