Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: USB 3.0 status in NetBSD-current?

> That may not help.
> A USB2 cable should still leave you using the xhci driver - just at the
> lower speed.

> There is some 'magic' needed to hand over the port from ohci? to xhci
> (which probably require correct parsing of ACPI data to work out which
> usb2 port the xhci port is linked to).

> If the port isn't handed over (ie no xhci support in the kernel) the
> USB port should still run at USB2 speeds.

> There are also significant differences between the xhci hardware.
> Some of which are definitely bugs, some are probably documentedd bugs,
> other are just the hardware engineers making life extremely difficult
> for the software engineers.

> For example:
> The xhci controller supports arbitrary scatter gather except:
> 1) The maximum fragment size is 64k.
> 2) Fragments can't cross 64k address boundaries.
> 3) The end of a ring segment must happen at the end of a USB packet.

>         David

There are significant differences in hardware, not only for USB 3.0 and USB < 
3.0, but other things as well, such as SCSI cards, and network adapters, both 
wired and wireless.

When booted into my NetBSD-current (6.99.43) amd64 USB 2.0 stick installation, 
I plugged in an 8 GB USB 2.0 stick (Kingston Data Traveler) with an older 
6.1_STABLE i386 installation to copy an xinitrc.icewm file.

It was not recognized as a character device, wouldn't mount.  So I made the 
copy by booting my FreeBSD 10.0-STABLE USB 3.0 Kingston Data Traveler 
installation, and that worked.

Normally, that USB stick with NetBSD 6.1_STABLE i386 worked in NetBSD.


Home | Main Index | Thread Index | Old Index