Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Any recent changes to amd64 timecounters?

I've got an older amd64 machine running on an ASUS M4A88T-M motherboard and it works just fine with NetBSD 6.99.17 (current from 2013-02-22).

But when I tried to upgrade to today's 6.99.23, the boot process hangs right after

        amdnb_misc0 at pci0 dev 24 function 3: AMD NB Misc Configuration
        pchb4 at pci0 dev 24 function 4: vendor 0x1022 product 0x1204 (rev. 
        isa0 at pcib0
        pckbc0 at isa0 port 0x60-0x64
        pckbd0 at pckbc0 (kbd slot)
        pckbc0: using irq 1 for kbd slot
        wskbd0 at pckbd0: console keyboard, using wsdisplay0

When booting the 6.99.17 kernel, the next few lines are

        timecounter: Timecounter "clockinterrupt" frequency 100 Hz quality 0
        timecounter: Timecounter "TSC" frequency 3214618050 Hz quality 3000
        uhub0 at usb2: vendor 0x1002 EHCI root hub, class 9/0, rev 2.00/1.00, 
addr 1
        uhub0: 6 ports with 6 removable, self powered

followed by the rest of USB configuration.

I tried to disable pckbc* during the boot, but it still hangs, between the lines for isa0 and timecounters.

This motherboard has a AMD 710 southbridge. Three other machines with the same CPU and Northbridge (880G) chips, but with AMD 850 SB, boot the new kernel just fine.

So, has something in this area changed recently?

| Paul Goyette     | PGP Key fingerprint:     | E-mail addresses:       |
| Customer Service | FA29 0E3B 35AF E8AE 6651 | paul at    |
| Network Engineer | 0786 F758 55DE 53BA 7731 | pgoyette at |
| Kernel Developer |                          | pgoyette at  |

Home | Main Index | Thread Index | Old Index