Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Persistent green messages interrupting console on NetBSD 6.99.19 i386

from Ian D. Leroux:

> On Tue, May 7, 2013, at 7:07, Thomas Mueller wrote:
> > I keep getting green messages on the console, on a black background
> > and white or light gray regular text, making it impossible to do
> > anything useful.
> By default, kernel output (error messages, typically) are in green,
> whereas userland output is uncoloured.

> > It is practically impossible to use vi editor because of all that
> > green garbage, like
> On i386, you can switch to another virtual terminal (once you have
> enabled it, see below) with Ctrl-Alt-F<n>.  The kernel output only gets
> sent to the console, which is usually accessed at Ctrl-Alt-F1.  Other
> virtual terminals won't see it (or any other console output).

> In fact, I generally disable the first virtual terminal on my machines
> so that Ctrl-Alt-F1 is *only* for console output, and all user
> interaction takes place on other vtys, precisely to avoid mixing error
> and log messages into my user interface.
> > May  6 23:18:38  /netbsd: sd0(umass0:0:0:0):  Check Condition on CDB:
> 0x35 00 00 00 00 00 00 00 00 00
> > May  6 23:18:38  /netbsd:    SENSE KEY:  Vendor Unique
> > May  6 23:18:38  /netbsd:     ASC/ASCQ:  Logical Unit Not Ready, Cause
> > Not Reportable
> > May  6 23:18:38  /netbsd:
> Looks like a problem with a USB drive.  What hardware is sd0?

> > I might add, only one VT works; I can't go to another, even though I have
> > wscons=YES in /etc/rc.conf .

> You need to enable ttyE1 (or any others you want to use) by changing the
> status from "off" to "on" in /etc/ttys.

> -- IDL
I tried what you advise, checking /etc/ttys, and changed "off" to "on", for 
NetBSD 6.1_RC4 i386 and amd64 on 8 GB USB sticks, and tested the i386 
installation on the old computer, succeeded in getting apparently 4 virtual 
terminals, and the mouse worked in pkgsrc modular Xorg, which is often not the 

If the mouse in X is dead, I might be able to use a keyboard-oriented window 
manager like ratpoison but would still not be able to use many X-oriented 

But the first virtual terminal quit responding to the keyboard, nothing showed 
on screen.  Exiting X, I got a dim screen, a bug in how NetBSD reacts with ATI 
r128 graphics card.

I can access the NetBSD partition from FreeBSD for NetBSD 6x and HEAD, but not 
netbsd-5 due to not being able to read the disklabel, installed by sysinst.

I also copied /usr/mdec/boot to /boot after seeing these files were different, 
for netbsd-6 and HEAD where I could do this from FreeBSD.  Maybe I also could 
run installboot?

The USB stick that produces the green garbage is a Kingston Data Traveler 16 
GB.  FreeBSD can read and write it OK, even NetBSD 5.1_STABLE amd installed 
from binary sets in summer 2011 didn't give me all those green error messages, 
though it was buggy in other ways.


Home | Main Index | Thread Index | Old Index