Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Crash in getenv(3)

Christos Zoulas wrote:
>On Apr 10,  2:14pm, (Robert Swindells) wrote:
>-- Subject: Re: Crash in getenv(3)
>| >>I have got debug libraries built for this machine but haven't worked out
>| >>how to link against them yet.
>| >Build a system with MKDEBUG=yes and you'll get more info.
>| It was built with MKDEBUG=yes, what else do I need to do to get gdb
>| to pick up the debug libraries ?
>Yes, I meant to fix that... The problem is that binaries that link with
>/lib/ look for debug symbols in 
>    /usr/libdata/debug/usr/lib/
>The following trick fixes it... I am not sure if adding a symlink in the
>build for shared libraries in /lib is the proper way though (yet).

Nope, still doesn't work for me:

# ls -l /usr/libdata/debug/lib
total 4
drwxr-xr-x  3 root  wheel  512 Apr  7 19:06 i386
lrwxr-xr-x  1 root  wheel   47 Apr 10 16:45 -> 
drwxr-xr-x  2 root  wheel  512 Apr 10 12:35 npf

# gdb /bin/ls
GNU gdb (GDB) 7.3.1
Copyright (C) 2011 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64--netbsd".
For bug reporting instructions, please see:
Reading symbols from /bin/ls...(no debugging symbols found)...done.

I get the same result as before trying to debug the app that crashes too.

Robert Swindells

Home | Main Index | Thread Index | Old Index