Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Output format improvment for ifconfig(8)

I don't object to the multiline part (although if anyone thinks there
are scripts it will break, that's a fair point), but I don't agree with
the name change of 'capabilities' to 'capable'.

From net/if.h:

        uint64_t if_capabilities;       /* interface capabilities */
        uint64_t if_capenable;          /* capabilities enabled */

so the first one being "capabilities" seems correct, and the existing
"enabled" matches the comment.

Attachment: pgpAZ0Ty7RaKv.pgp
Description: PGP signature

Home | Main Index | Thread Index | Old Index