Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: call for testing: completing the device/softc split

matt@ wrote:

> On Oct 10, 2012, at 10:55 AM, Izumi Tsutsui wrote:
> > I wrote:
> > 
> >> ite chnages seem to cause silent hang at early bootstrap at least on XM6i,
> >> so I'll check it on real X68030 with serial console later.
> >> (IIRC atari's ite also had annoying quirks around console probe code..)
> > 
> > I've also fixed and committed x68k ite.
> > 
> > It has a static struct softc for early console,
> > so we should also prepare a static struct device
> > after it's split out from softc.  Oh well.
> No.  Just use a softc size of 0 and set self->dv_private to
> the static softc in the attach and sc->sc_dev to self as well

Hmm.  If the driver requires whole members in the static softc,
probably it's right.

But I guess the current implementation of the ite driver is
a result of kludges to adapt ancient drivers (derived from HPBSD)
to 4.4BSD newconfig.  The only necessary stuff for early console
seems struct grf_softc that is copied in iteattach (as
struct rasops_info in modern wscons drivers), but
struct device is still referred in iteinit() etc only to get
a device unit number, which is not necessary for console.

Anyway, the ite drivers should be replaced by wscons in future
and troubles during early console are really annoying,
so I'd like to keep changes minimum on device_t/softc split.

Izumi Tsutsui

Home | Main Index | Thread Index | Old Index