Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Matrox graphics adapters cannot read EDID information from monitor


I have just tried to change my monitor from an old CRT to a
modern LCD one.  The old setup had explicit ModeLine
configuration stanzas for the CRT in the xorg.conf file.  For
other LCD monitors, connected to other systems, I normally leave
everything blank in xorg.conf, and let X figure out the details
of the connected monitor(s).  However, when I tried to connect
the new Philips Brilliance 245P to my systems (through a AutoView
commander console switch) X could not fetch the mode information
from the monitor, and defaulted to the one of the low resolution
VESA modes.  I then connected the monitor directly to one of the
systems, but that did not make any difference.  The graphics
adapter in this system is identified as:

vga1 at pci1 dev 0 function 0: Matrox MGA G400 AGP (rev. 0x85)

and the system runs NetBSD/i386 5.1_STABLE from around October 2011.

In /var/log/Xorg.0.log I also found:
[ ... ]
(II) MGA(0): I2C bus "DDC P1" initialized.
(II) MGA(0): I2C device "DDC P1:E-EDID segment register" registered at address 
(II) MGA(0): I2C device "DDC P1:ddc2" registered at address 0xA0.
(--) MGA(0): No DDC signal
[ ... ]
(II) MGA(0): VESA VBE DDC supported
(II) MGA(0): VESA VBE DDC Level none
(II) MGA(0): VESA VBE DDC transfer in appr. 0 sec.
(II) MGA(0): VESA VBE DDC read failed

I also tried this on another system, with a graphics adapter that
is identified as:

vga1 at pci4 dev 4 function 0: vendor 0x102b product 0x0532 (rev. 0x0a)

which would be a Matrox MGA G200eW, and the system runs
NetBSD/amd64 -current.

Then I connected the monitor to the VGA port on my Lenovo laptop,
where the graphics adapter is identified as:

vga1 at pci0 dev 2 function 0: vendor 0x8086 product 0x2a42 (rev. 0x07)

which would be a Intel 82GM45 Integrated Graphics Device.  Then
X could fetch the EDID information from the monitor:
(II) intel(0): I2C bus "CRTDDC_A" initialized.
(II) intel(0): I2C device "CRTDDC_A:ddc2" registered at address 0xA0.
(II) intel(0): I2C device "CRTDDC_A:ddc2" removed.
(II) intel(0): I2C bus "CRTDDC_A" removed.
(II) intel(0): EDID vendor "PHL", prod id 2206
(II) intel(0): EDID vendor "LEN", prod id 16438

and xrandr -q reported the available modes for the monitor.

So, is there a problem with NetBSD, Xorg, DDC and Matrox graphics
"Programming graphics in X is like finding sqrt(pi) using Roman
 numerals."                     -- Henry Spencer

Home | Main Index | Thread Index | Old Index