Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Test-bed time-out

Chuck Silvers wrote:
> thanks for the info.  I tried to reproduce this myself but didn't have any 
> luck.
> I ran that one test program in a loop for 1/2 hour (several thousand cycles)
> but it never got stuck.  that was on a real system, not qemu.  also, amd64.

Please try to reproduce it under qemu.  It's just four lines of
typing, assuming you have misc/py-anita installed:

  $ anita interact
  login: root
  # cd /usr/tests/rump/rumpvfs
  # while true; do atf-run t_etfs; done

> that stack looks like the unmount thread wasn't sleeping, can you confirm
> that the thread is continuing to run even though the unmount doesn't complete?
> if that's the case, could you try to narrow down what it's doing?

It's looping in ffs_sync(), between ffs_vfsops.c line 1649:

  1649            for (vp = TAILQ_FIRST(&mp->mnt_vnodelist); vp; vp = nvp) {

and line 1742:

  1742                            goto loop;

and ffs_sync() never returns.
Andreas Gustafsson,

Home | Main Index | Thread Index | Old Index