Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: building 'current' amd64 on linux

On 03/10/2012 05:07 AM, David Laight wrote:
I just tried to build 'current' on a linux (fedora 16) system.
i386 built fine - but wasn't the build I wanted!
The build of amd64 failed trying to compile gcc in tools.
It fails trying to 'make all' in obj/tools/gcc/build/32/zlib
- which doesn't even have a Makefile.

I forced 'MULTILIB_ARGS= --disable-multilib' in src/tools/gcc/Makefile
and the build suceeded.


I'm trying to build on a qemu/kvm 64-bit box and I cannot even build the 
building with:

    ./ -O /usr/src/obj -T /space/tools -R /space/release -D /space/build

Keeps failing with:

checking for __gmpz_init in
configure: error: libgmp not found or uses a different abi

If I run (I probably should not expect this to work):
# cc -L/space/tools/ -lgmp

I get:
cc -L/usr/src/tools/lib -lgmp
ld: skipping incompatible /usr/src/tools/lib/libgmp.a when searching for -lgmp
ld: cannot find -lgmp

this is from a fresh checkout via:

cvs -d co -r netbsd-6 src

I'm obviously missing something.
I do not have an /etc/mk.conf in place just in case the one I (like to) use 
have been doing something wonky, but, there or not, I get the same result as 


Home | Main Index | Thread Index | Old Index