Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: raidframe with R5/RS not reconstructing?

On Sun, 12 Feb 2012 06:50:52 -0600 (CST)
"John D. Baker" <> wrote:

> An experimental oversight caused one unit of my raid to get marked
> as failed, even though nothing's wrong with the hardware.  It's now
> running in degraded mode and all the data appear to be intact.
> No problem, I thought.  'raidctl -R /dev/wd8a raid0' should put it
> back to its old self.
> But it doesn't.  It immediately reports 12% completion and sits there
> (almost 9 hours now) with no apparent progress and no ETA computed
> (00:00).
> I suppose this is the acid test for the little-used RAID 5 w/Rotated
> Sparing option.  The last time I needed it (in NetBSD-4 days on
> sparc), it worked just fine.

For those playing along at home:  

I am able to replicate the issue, and have an understanding of what the
problem is (basically, with rotated sparing every nth stripe of an
n-disk RAID5_RS set doesn't generate any writes during reconstruction,
and the logic in the code is expecting there to be writes for every

Just a simple matter of finding the correct fix... 

(the reason this worked back in NetBSD-4 days is that the
reconstruction map code has been reworked since then, and this bug
was introduced...)


Greg Oster

Home | Main Index | Thread Index | Old Index