Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: sqlite3 in base not suitable for firefox

In article <>,
Thomas Klausner  <> wrote:
>When compiling firefox (more exactly, xulrunner) against the sqlite3
>included in the NetBSD base system, configure errors out with:
>checking SQLITE_CFLAGS...  
>checking SQLITE_LIBS... -lsqlite3  
>checking for SQLITE_SECURE_DELETE support in system SQLite... (cached) yes
>checking for SQLITE_THREADSAFE support in system SQLite... yes
>checking for SQLITE_ENABLE_FTS3 support in system SQLite... yes
>checking for SQLITE_ENABLE_UNLOCK_NOTIFY support in system SQLite... no
>configure: error: System SQLite library is not compiled with
>*** Error code 1
>Is there a reason this is not enabled in the base system version of
>sqlite3, or should we just enable it?
I am doing it.


Home | Main Index | Thread Index | Old Index