Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: build failure w/ libtre update

On Sun, Nov 06, 2011 at 06:21:41PM +0000, Matthias Scheler wrote:
> On Sun, Nov 06, 2011 at 05:11:35PM +0000, wrote:
> > > BTW: does that happen with the default options as well or do you use 
> > > "USE_SSP"?
> > 
> > Am running "USE_SSP=yes",
> Please mention such options (or "USE_INET6=no") if you report build failures.
> > ... but that's indicated as default on AMD64 anyway.
> Not as far as I can tell. It is activated for parts of the the tree
> (e.g. "libc" or the kernel) but not in general.

To be sure we're talking about the same thing, I set this directive in
/etc/mk.conf, and mk.conf(5)  says:

     USE_SSP        Can be set to ``yes'' or ``no''.  Indicates whether GCC
                    stack-smashing protection (SSP) support, which detects
                    stack overflows and aborts the program, is enabled.  This
                    imposes some performance penalty.

                    Default: ``yes'' on i386 and amd64, otherwise ``no''.

Docs need updatin or clarification?



>       Kind regards
> -- 
> Matthias Scheler                        

Brad Harder
Method Logic Digital Consulting

Home | Main Index | Thread Index | Old Index