Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Problems with iwi0


I have troubles with iwi0, even now that I updated yo the current kernel.

I run the following

ifconfig bge0 down
route delete default
ifconfig iwi0 ssid xxxxxxxx
ifconfig iwi0 nwkey 0xYYYYYYYYY
dhclient iwi0

dhclient is capable of receiving a correct IP, the default route seem scorrect but the interface remains "down" and trying to ping both a LAN or an internet hosts says "network is down". The first time dhclient is run, ifconfig complains that it cannot assign an IP address.

The strange thing is that on a second network, with the same ssid and key (other laptops just hook on to one or another without problems). It works.

I'm a bit clueless. I tried ifconfig down/up, rerunning dhclient, forcing manually a valid IP. The network stays down.


iwi0 at pci2 dev 4 function 0: vendor 0x8086 product 0x4220 (rev. 0x05)
iwi0: interrupting at ioapic0 pin 21
iwi0: 802.11 address 00:15:00:38:b1:9e
iwi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
iwi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps

Home | Main Index | Thread Index | Old Index