Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: of tools (nbhost-mkdep) fails on i386 vm

On Sat, Oct 01, 2011 at 09:16:52 -0400, "Valeriy E. Ushakov"
<> wrote:

>> install ===> host-mkdep
>> rm -f host-mkdep
>> CC=cc /bin/sh /usr/src/tools/host-mkdep/configure
>> --cache-file=config.cache
>> configure: loading cache config.cache
>> configure: creating ./config.status
>> config.status: creating host-mkdep
>> chmod +x host-mkdep
>You should see here instead (module your TOOLDIR):
>install ===> tools/host-mkdep
>mkdir -p /usr/nb/tools/bin
>cp host-mkdep /usr/nb/tools/bin/nbhost-mkdep
>chmod +x /usr/nb/tools/bin/nbhost-mkdep
>So you should investigate why this step misbehaves.  You can cd to
>src/rools/host-mkdep and run $TOOLDIR/bin/nbmake-$arch install to run
>just this step after doing whatever changes you think might affect it
>(wrong timestamps, verifying that your source tree is clean, etc).


I apologize, but I really only know how to run when I
do what you suggest as a "test" I have no idea what it's doing,
but it does not appear to use the correct paths (that's what does in the background)...

the first time I ran this:
xperiment 43 # /usr/tools/bin/nbmake-i386 install

it gave me some output, but not the second time...nothing
I do not know where it put the file.
It's not in /usr/tools/bin...?
xperiment 45 # ls /usr/tools/bin/
nbmake*       nbmake-i386*
It's not in /usr/src/tools/host-mkdep either?
xperiment 46 # ls -las
total 94
 2 drwxr-xr-x   3 root  wheel    512 Oct  1 09:57 ./
 4 drwxr-xr-x  98 root  wheel   2560 Oct  1 10:06 ../
 2 drwxr-xr-x   2 root  wheel    512 Oct  1 09:57 CVS/
 2 -rw-r--r--   1 root  wheel    823 May 13  1942 Makefile
76 -rwxr-xr-x   1 root  wheel  77479 May 13  1942 configure*
 2 -rw-r--r--   1 root  wheel    336 May 13  1942
 6 -rw-r--r--   1 root  wheel   5752 May 13  1942

The time stamps look weird...I just deleted the directory and did a fresh
update from cvs to get a clean copy...

I run the following from /usr/src
cvs -q up -dPAC
That comes up clean...

more help?

Home | Main Index | Thread Index | Old Index