Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Issues with NetBSD-5.1, xen and amd64 machines.

        Hello.  I've now got output from xen and the dom0 kernel.  It panics,
but I think I can make progress from here.
The problem with the lack of boot messages was that it wasn't obvious to me
that NetBSD starts counting serial ports at com0, while xen starts at com1.
So,  I assume that the example in the boot.cfg(5) man page has output from
NetBSD going to com0, as NetBS counts it, and xen output going to com1, as
NetBSD counts it.  In fact, the output of both is going to the same serial
port with each using its own numbering convention.  Should I update the
boot.cfg(8) man page to make this more clear?

On Sep 22, 11:12am, Brian Buhrow wrote:
} Subject: Re: Issues with NetBSD-5.1, xen and amd64 machines.
}       Hello.  Following up on Manuel's suggestion of using a newer /boot
} file to get things going, I've installed the /usr/mdec/boot file from the
} amd64 snapshot from 201109201940z
} It still doesn't work, but the output is slightly different.  Is there  any
} way to get more verbosity in the loading process?
} -thanks
} -Brian
} >> NetBSD/x86 BIOS Boot, Revision 5.9 (from NetBSD 5.99.55)
} >> Memory: 607/3136000 k
}      1. Boot Xen and Dom0
}      2. Boot normally
}      3. Boot single user
}      4. Disable ACPI
}      5. Disable ACPI and SMP
}      6. Drop to boot prompt
} Choose an option; RETURN for default; SPACE to stop countdown.
} Option 1 will be chosen in 5 seconds.
} 951808+371200=0x1430c0
} WARNING: couldn't open ffs (//ffs/ffs.kmod)
} Loading /netbsd 
} WARNING: 1 module failed to load
>-- End of excerpt from Brian Buhrow

Home | Main Index | Thread Index | Old Index