Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: USB3?

> On Fri, 02 Sep 2011, Thomas Mueller wrote:
> > I am now on a new Intel Sandy Bridge system, have a Western 
> > Digital 3 TB My Book Essential USB 3.0 hard drive, and NetBSD 
> > can't see it at all.

> Try plugging the drive into a USB2 port.  It will be slow, but 
> it's more likely to work.

> --apb (Alan Barrett)

I tried that, and the USB 3 drive was not readable to any OS.  However, on the 
older computer, from July 2001, when USB 2.0 had been introduced but was not 
yet widely available on motherboards, the USB 3.0 drive was recognizable but 
would have been horribly slow, USB 1.1 speed.  I could see there was one big 
NTFS partition covering the whole disk, 2.7 TB, on MBR partitioning scheme.

I was able to copy the software on that drive on the newer computer, with a 
newer version of the System Rescue CD, using gdisk to migrate to GPT; it saved 
the data, which I subsequently copied to a USB stick, thus freeing the USB 3.0 
hard drive, 3 TB, for better things.

> There are not messages produced by the kernel for those devices?

> christos

I tried to read from /var/run/dmesg.boot on the 16 GB Kingston Data Traveler 
where I have NetBSD 5.1_STABLE amd64 installed, and couldn't find anything I 
could relate to the USB 3.0 ports or hub.  I also tried that with the 4 GB 
Ativa USB stick where I installed root of NetBSD-current, but couldn't read 
that at all from FreeBSD.  But I think I remember something about a USB hub not 
functional, or whatever word was used.

From Aleksej Saushev <>:

> There is known problem with Kingston Data Travellers, it doesn't involve USB 
> 3.

Only one model or group of models of Kingston Data Travelers, but OK on both 
the old and new computer with FreeBSD and Linux.

I installed NetBSD 4.0 i386 and updated to 4.0.1 on an older 4 GB Kingston Data 
Traveler, and installed 5.1_STABLE amd64 on a newer 16 GB Kingston Data 
Traveler: functional with respect to the USB stick, but goes into reboot if I 
try anything X-related like startx or Xorg -configure.


Home | Main Index | Thread Index | Old Index