Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Incompatibilities of userland 5.99.45 and 5.99.48

On 3/25/11 2:57 AM, Frank Wille wrote:
On Thu, 24 Mar 2011 08:28:36 -0700
Matt Thomas<>  wrote:

These days I tried to update an ofppc and a sandpoint machine to
5.99.48. Both fail with pkgsrc binaries compiled under 5.99.45,
which worked before.

The segmentation fault always involves libpthread and __cxa_atexit().
I'm going to bet that this is due to crt0 overwriting r2 which was set
by ld.elf_so.  I think I can fix this with a kludge.

A workaround is in , can you
try it?
I patched my sources and recompiled the whole userland.
Then I updated my sandpoint system with base.tgz.

Unfortunately that changes nothing. Exactly the same crash as before.

I think I'm seeing the same thing (or at least something related) on macppc - after the "preserve l_private across forks" change, the number of test failures jumped from 11 to 243 (see ) . As in Frank's case, the ppc-tls-diff.txt change does not actually fix it.


Home | Main Index | Thread Index | Old Index