Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: installing on thinkpad x201i

On 1 October 2010 11:52, Johan Danielsson <> wrote:
> Hello,
> I've been trying to install NetBSD/amd64 on a Thinkpad X201i (Core
> i3). I would say I've come to a point where it's usable.


I have been running amd64-current on a ThinkPad X201 (Core i5) as my
primary OS since June, and have been rather happy with it too.   So
far, it has met my needs for practically everything other than
connecting to external projectors (vesa doesn't like xrandr),
connecting to wpa2-enterprise networks (although wpa2-personal works
fine), and occasionally running MATLAB (impressively, MATLAB actually
runs under Linux emulation after the relatively recent updates, but
its Java components don't work--perhaps due to pkgsrc compat libs'
datedness--which makes it unusable).

> At first, kernels would crash pretty much immediately. This was true
> for both 5.0.x, and current, both i386 and amd64. After some poking
> around I figured out that the problem was that iomem extent storage
> was too small. This BIOS seem to announce 33 (IIRC) memory segments,
> and there is only room for 16 in iomem_ex_storage. With this number
> bumped to 40, it made it all the way to single users mode, with most
> hardware detected.
> Is there a reason (other than historical) for this low number (16), or
> can this be increased with out problem (other than the loss of a few
> bytes)? Can I commit this change, or should this be solved in some
> different way altogether?

I'm not sure I understood the problem, but I never had any such issues.


> Second, the i82577 PHY lacks a proper driver. I don't know if any of
> the present intel phy drivers (iophy, igphy, ikphy, have I missed
> any?) are close enough, but they don't match as is.
> To get ukphy to work, I had to remove the PHY reset; all registers
> read as zero after reset. I suppose this PHY needs some special voodoo
> after reset.

I think this is non-trivial.  See


> The "final" big issue is X. Our aging X source doesn't know about the
> fancy Intel GMA HD graphics. The VESA driver works, but it just a bit
> too slow for comfort. Is anyone actively working on fixing this?
> Moving to modern versions seem to be quite a lot of work involving
> lots of TLA:s (GEM, KMS and whatnot). Personally I would be ok with
> something that's a bit faster than VESA (like moving windows
> effortlessly).

This requires some major work.  See my posts in


Besides speed, my main disappointment with the vesa driver is that on
the few occasions that I tried, I could not get it to work with
external displays (i.e. video projectors), which somehow goes against
one of the primary reasons for owning a laptop (this may be possible
to do, but I was always in a hurry and had to resort to using another
laptop after xrandr did not work).

> Other than this, WLAN (Intel 6200) seems to work (except for 11n),

I can use WLAN, but not to connect to wpa2-enterprise networks, which
wpa_supplicant does not seem to recognize (they work fine on Linux):


Also the connection gets dropped rather frequently (i.e. every 5-6
mins) on my home network, but much less often at work (I suspect my
Siemens Gigaset router combined with incompetence on my part is partly
to blame for this).

> BT
> and memory card reader attaches, but I haven't used them,

Neither have I.

> neither have
> I tried audio,

Works fine for me.

> suspend,

#sysctl -w machdep.sleep_state=3 panics and reboots for me with a
(slightly customized) kernel from 27 Aug. (you have to disable ukphy
in kernel since it does not support suspend).  There is no crash dump:

acpi0: entering state S3
Flushing disk caches: 8 done
uvm_fault(0xffff80004e710e88, 0x0, 4) -> e
fatal page fault in supervisor mode
trap type 6 code 10 rip 0 cs 8 rflags 10246 cr2  0 cpl 6 rsp ffff80004e760928
panic: trap
cpu2: Begin traceback...
uvm_fault(0xffff80004e710e88, 0x0, 1) -> e
fatal page fault in supervisor mode
trap type 6 code 0 rip ffffffff801e45ef cs 8 rflags 10246 cr2  0 cpl 6
rsp ffff80004e7604e0
Skipping crash dump on recursive panic
panic: trap
Faulted in mid-traceback; aborting...rebooting...

> or any other features.
> /Johan

It's great to know that others are running NetBSD on hardware very
similar to one's. :)


Home | Main Index | Thread Index | Old Index