Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: unable to update pkgsrc from 1.6.2

Am 01.04.2010 um 12:33 schrieb Joerg Sonnenberger:

On Thu, Apr 01, 2010 at 11:50:15AM +0200, Jan-Hinrich Fessel wrote:
Is there any way to force pkgsrc's build system to actually delete
the old files and install the new ones?
Or must I do a replace instead of an upgrade?  What does this do to
dependencies I als want to be updated?

The problem is that you seemed to have ended up with multiple versions
of readline in the database. Just do another "pkg_delete -f readline".

thanks, pkg_delete readline twice fixes this issue. And yes, looking at pkg_info from before the upgrade, two packages identified themselves as "readline". Is there any way to reduce those duplicate instances to only one?

I would also suggest "pkg_admin rebuild" as the database is most likely

Yes, it is semi-broken. Actually, pkg_admin is complaining about packages in the db but not on disk.


Home | Main Index | Thread Index | Old Index