Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Booting NetBSD using UEFI on Dell T610


I got stuck and need some help.

I am trying to install NetBSD/amd64 on Dell T610 using GPT partition
scheme and boot it up with UEFI. I followed the instructions here, but the machine doesn't boot.

That's for booting from a GPT via PC BIOS.

I can't even boot with PC BIOS. I tried to adjust the beginning of the GPT partition in MBR, but then I get 'Error read data' from bootxx_fat16.

As far as I know, UEFI is looking for BOOTx64.EFI file, which should be
located on EFI partition (the first one on disk).

Again, gptboot doesn't provide this.

I have occasionally worked on a bootloader that would provide this,
but my lack of real hardware with UEFI doesn't help.

How can I get it boot? Any advice is much appreciated.

Use a normal MBR?

I have >2TB RAID frame. With MBR I loose much of the diskspace.

Kind regards,

Home | Main Index | Thread Index | Old Index