Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

gimp instability on NetBSD-current


On a 5.99.24/amd64, when I start gimp, it sometimes coredumps.
Starting it multiple times in a row it then works at one point.

When I start it with jpgs as command line arguments, it nearly always

Once it's running, it seems fine.

Program terminated with signal 11, Segmentation fault.
#0  0x00007f7ffdc068e7 in imalloc () from /usr/libexec/ld.elf_so
(gdb) bt
#0  0x00007f7ffdc068e7 in imalloc () from /usr/libexec/ld.elf_so
#1  0x00007f7ffdc06a5b in xmalloc () from /usr/libexec/ld.elf_so
#2  0x00007f7ffdc06119 in _rtld_symlook_default () from /usr/libexec/ld.elf_so
#3  0x00007f7ffdc06444 in _rtld_find_symdef () from /usr/libexec/ld.elf_so
#4  0x00007f7ffdc03cf1 in _rtld_relocate_nonplt_objects ()
   from /usr/libexec/ld.elf_so
#5  0x00007f7ffdc05cab in _rtld_relocate_objects () from /usr/libexec/ld.elf_so
#6  0x00007f7ffdc05ae1 in dlopen () from /usr/libexec/ld.elf_so
#7  0x00007f7ff420186c in g_module_open ()
   from /usr/pkg/lib/
#8  0x00007f7ffd401ae3 in gimp_module_open ()
   from /usr/pkg/lib/
#9  0x00007f7ffd401f03 in gimp_module_load ()
   from /usr/pkg/lib/
#10 0x00007f7ffd402136 in gimp_module_new ()
   from /usr/pkg/lib/
#11 0x00007f7ffd402536 in gimp_module_db_module_initialize ()
   from /usr/pkg/lib/
#12 0x00007f7ffc007d9c in gimp_datafiles_read_directories ()
   from /usr/pkg/lib/
#13 0x00000000005efae0 in gimp_modules_load ()
#14 0x00000000005eb053 in gimp_restore ()
#15 0x0000000000466e00 in app_run ()
#16 0x0000000000467c38 in main ()

Has anyone else seen this?

Home | Main Index | Thread Index | Old Index