Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: NetBSD-current no longer boots after install

On Jan 16, 2010, at 8:44 AM, Andreas Gustafsson wrote:

> Steven Bellovin wrote:
>>>   cannot mount root, error = 79
>>>   root device (default wd0a): 
>> That message generally means you didn't install the new modules.
> There is no "you".  The installation was done by a fully automated,
> scripted invocation of sysinst by the misc/py-anita package, and the
> exact same procedure worked the previous day.
> --

I'll amend my comment to use the passive voice: that message generally 
indicates that the necessary kernel modules were not installed.  I believe it 
happens because ffs needs to be present to mount (the usual) /, and the kernel 
can't find it.

I don't know why it should have worked earlier.  Were the old and new versions 
the same?  Look at /stand/<arch> and see if there's a directory for the new 
kernel version.  See what the modification dates are on the working system.  If 
you're missing the directory on the non-working, can you copy it over from some 
other machine?

Then take all that info and send-pr it, I suspect...

                --Steve Bellovin,

Home | Main Index | Thread Index | Old Index