Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

building current tools fails with NetBSD 3.1.1


yesterday I updated the current source, cleaned my obj directory and
tried to build tools for ofppc on my NetBSD/macppc 3.1.1 machine:

===> command: ./ -m ofppc tools
===> started: Thu Jan 14 23:14:31 CET 2010
===> NetBSD version:   5.99.23
===> MACHINE:          ofppc
===> MACHINE_ARCH:     powerpc
===> Build platform:   NetBSD 3.1.1_PATCH macppc
===> HOST_SH:          /bin/sh
===> TOOLDIR path:     
===> DESTDIR path:     /home/frank/netbsd/current/src/obj/destdir.ofppc
===> RELEASEDIR path:     /home/frank/netbsd/current/src/obj/releasedir
===> makewrapper:      
#      link  lint2/lint2
cc -O -I/home/frank/netbsd/current/src/tools/compat/obj 
-I/home/frank/netbsd/current/src/tools/lint2/../compat -DHAVE_NBTOOL_CONFIG_H=1 
 -D_FILE_OFFSET_BITS=64  -DPASS=\"lint2.h\" 
   -o lint2 main2.lo hash.lo read.lo mem.lo mem2.lo chk.lo msg.lo emit.lo 
emit2.lo inittyp.lo tyname.lo -L/home/frank/netbsd/current/src/tools/compat/obj 
-lnbcompat -lz
chk.lo(.text+0x1cac): In function `chkrvu':
: undefined reference to `__arraycount'

*** Failed target:  lint2

I'm quite sure building tools on this machine worked a few weeks ago.
Did something change which breaks building tools on NetBSD 3.1?
Am I forced to upgrade? :|

Frank Wille

Home | Main Index | Thread Index | Old Index