Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: strange networking stack?

On Mon, Nov 09, 2009 at 11:04:27AM -0500, Noah McNallie wrote:
> Right, well I don't have a switch at this house to have such a 
> configuration with the laptop. The laptop has it's own wireless card and 
> I was simply using it as a way to describe how the laptop running 
> opensolaris was capable with this bridge just fine. Though, the bridge 
> is the other way around.
> <ultra 30> ----wired---- <bridge> - - - wifi - - - <linksys router>

hmm... without the capability to have an extra machine plugged in on
one side of the bridge or the other it's going to be a bit difficult
to figure out what's going on.  
Just to throw an idea out there: I once had a somewhat similar setup, and 
one of the things I had to work around was differing MTUs used by NetBSD 
and what the "router" would let through.  However, if you can't even ping 
the router from the NetBSD machine then something else is going on.

> I have ran tcpdump in the past, though can't currently as I have solaris 
> on the u30, I will work today on getting netbsd back on it. If I 
> remember correctly some strange packets passed by from the linksys (if 
> any) yet it did not respond or route any bridged packets from the u30. 
> I'm curious if it is a compatibility issue between netbsd and the 
> linksys router. I will update this once I have it available.

Does it work if you plug the ultra 30 directly into the linksys, bypassing
the wifi entirely?


Home | Main Index | Thread Index | Old Index