Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]


Hi jeff,
On Apr,Friday 3 2009, at 7:59 PM, Jeff Rizzo wrote:

Great to here that you are trying LVM :).

I've just started playing with the LVM stuff added in December, and I'm running into some issues - perhaps someone can point out either what I'm doing wrong or where the process itself is flawed.

I started off by building -current (as of yesterday) with MKLVM, so libdevmapper and lvm userland bits are installed. My kernel is fairly close to GENERIC (some extra debugging, mostly).

For this testing, I'm planning on using various pieces of wd1, a 750GB SATA disk. First step will be a single partition:

5 partitions:
#        size    offset     fstype [fsize bsize cpg/sgs]
c: 1465149105 63 unused 0 0 # (Cyl. 0*- 1453520) d: 1465149168 0 unused 0 0 # (Cyl. 0 - 1453520) e: 1465149100 68 unknown # (Cyl. 0*- 1453520)

...I'll be using /dev/rwd1e (yes, the offset is weird. disklabel ickiness that I didn't feel like dealing with)

After boot, I load the devmapper:

# modload dm

Then, try to pvcreate:

# lvm pvcreate /dev/rwd1e
 /dev/log: open failed: Operation not supported
 /dev/wd0a: open failed: Device busy
 Device /dev/rwd1e not found (or ignored by filtering).

I tried to reproduce this in my testing machine and it worked fine. Can you post log from
lvcreate -vvvv pvcreate /dev/rwd1e ?



Home | Main Index | Thread Index | Old Index