Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

hanging 5.0_RC2 nfs client and at debugger prompt

My NFS server is running on old 4.99.62.

My client is amd64 5.0_RC2.

I mounted the share and it appeared to mount fine. I started to use it and 
it saved 524288 bytes and then the tool (ftp) saving the file hung. I 
tried to unmount and the umount hung. (In "D" state according to ps.)

I then ran statd and lockd on the server a few minutes later and the 
umount and the hanging ftp exited. I am not sure if it was a coincidence 
or not.

I tried to ftp another file and it hung after creating a zero byte file on 
the nfs share.

I then read that lockd and statd should be running on the client too, so I 
tried to start. I think statd started and my client system locked up. I 
don't think lockd ever started. I can no longer ping the client and I 
can't change consoles on the client.

The server is still running fine. From a different 5.0_RC2 kernel amd64 
system (with some older userland), I can mount and use the share fine 
without rpcbind, statd, nor lockd running on the client.

Any ideas on how a NFS client can hang a system?

How can I troubleshoot this?

CTRL-ALT-ESC worked.

fatal breakpoint trap in supervisor mode
trap type 1 code 0 rip ffffffff804eb015 cs 8 rflags 202 cr2  7f7ffd635004 cpl 6
rsp ffff8000494eb9e8
Stopped in pid 0.2 (system) at  netbsd:breakpoint+0x5:  leave
db{0}> bt
breakpoint() at netbsd:breakpoint+0x5
wskbd_translate() at netbsd:wskbd_translate+0xb0e
wskbd_input() at netbsd:wskbd_input+0xba
pckbd_input() at netbsd:pckbd_input+0x54
pckbcintr() at netbsd:pckbdintr+0x81
intr_biglock_wrapper() at netbsd:intr_biglock_wrapper+0x1d
Xintr_ioapic_edge1() at netbsd:Xintr_ioapic_edge1+0xef
--- interrupt ---
x86_mwait() at netbsd:x86_mwait+0xd
idle_loop() at netbsd:idle_loop+0xe9

(Hopefully no typos above)

Any suggestions? (Still at the prompt.)

This is a new Toshiba Satellite L350-S1701 laptop which I still haven't 
really used yet.  The dmesg is here:

  Jeremy C. Reed

echo 'EhZ[h ^jjf0%%h[[Zc[Z_W$d[j%Xeeai%ZW[ced#]dk#f[d]k_d%' | \
  tr            '#-~'            '\-.-{'

Home | Main Index | Thread Index | Old Index