Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: X11R6 runtime compat. for fresh -current installation

On Fri, 13 Mar 2009 23:56:36 +0100
Bernd Ernesti <> wrote:

> And I haven't made it clear why I mentioined the X11 symlink.
> We introduced a new loction for the X11 libaries and binaries, which
> makes it harder to compile a program without using pkgsrc.
> Yes, there are situations where you need to do that.
> It seems other OS have a X11 symlink for such unusal places.
Let me repeat my suggestion: let's have /usr/X11 a symlink
to /usr/X11R6 or /usr/X11/R7 or /usr/pkg/x11 (I know, we don't have
that anymore -- was that the right decision?).  Among other things,
this will future-proof us when X11R8 comes out.

                --Steve Bellovin,

Home | Main Index | Thread Index | Old Index