Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Problem booting ("cannot mount root, error = 79")

Silas Silva wrote:
Hello all.

I just sup'ed the -current sources, compiled it and tried to replace my
current system (NetBSD 4.0) following instructions in

Compilation worked fine, but the kernel stops at the boot, with the
following error message:

boot device: wd0
root on wd0a dumps on wd0b
no file system for wd0b
cannot mount root, error = 79
root device (default wd0a):

wd0a is ok, because it works well with 4.0 kernel. I saw that some
changes were made in src/sys/kern/vfs_subr.c, in the vfs_mountroot()
function last days.

Does anybody know anything about it? Some critical changes was made that
I don't know? BTW, is there a list of incompatibility between two NetBSD

GENERIC kernel, i386 here.

Hi Silas --

NetBSD/i386 -current GENERIC kernel requires that kernel modules be installed; you must have an up-to-date bootloader ('man 8 boot') installed and the kernel module for your root filesystem (most likely ffs) must be installed in /stand/i386/<version>/modules/<filesystem>/<filesystem>.kmod

As NetBSD -current is going through some pretty major changes at the moment, you will probably have better luck with NetBSD 5.0_BETA (which doesn't have this kernel module requirement).

Hope this helps,

Home | Main Index | Thread Index | Old Index